Turn Status Page logo

Incident

Downtime

Resolved | Oct 21, 2020 | 14:13 GMT+02:00

The issue has been resolved for the 2 clusters impacted. The underlying technical root cause was a database migration causing a table lock on one of the applications' main tables. This was further complicated by automated database cleanup processes happening on the same table a the same time.

Our apologies for the downtime experienced.

Investigating | Oct 21, 2020 | 12:44 GMT+02:00

The fix we've applied has not yet had it's intended effect. We're continuing to investigate.

Resolution in progress | Oct 21, 2020 | 11:49 GMT+02:00

A fix is being released to the production environments impacted.

Open | Oct 21, 2020 | 11:17 GMT+02:00

Unfortunately we pushed a faulty release to 2 of our production clusters. This is causing downtime for https://app.turn.io. We are busy issuing a fix and the systems should be online again shortly.

Our sincere apologies for this inconvenience, we will provide updates here as we address the underlying issue.

Status Page powered by Admin Labs