Turn Status Page logo

Incident

Collections not loading intermittently

Resolved | Aug 25, 2020 | 09:23 GMT+02:00

Collection search indexing has been optimised to reduce load on the search backend. Search query and collection performance has been greatly improved as a result.

We're continuing to work on improvements to prevent this happening in future - in particular we're changing the way All Conversations is architected so that it is much faster and doesn't rely on search

Monitoring | Aug 25, 2020 | 09:22 GMT+02:00

Collection search indexing has been optimised to reduce load on the search backend. Search query and collection performance has been greatly improved as a result.

We're continuing to work on ways to prevent this occurring in future including changing the way All Conversations is architected so that it is much faster and doesn't rely on search.

Resolution in progress | Aug 19, 2020 | 14:35 GMT+02:00

To alleviate some of the load we'll be temporarily be turning off the total user count display for collections.

Resolution in progress | Aug 19, 2020 | 13:39 GMT+02:00

Currently, Collections rely on Search functionality to find conversations that match the Collection criteria. The All Conversations Collection, in particular, puts a high load on Search, slowing down the performance across all other Collections.

We're busy working on a change to how the All Conversation Collection functions to ensure that is performs faster.

Investigating | Aug 18, 2020 | 12:42 GMT+02:00

Some users are experiencing issues where Collections are loading a blank screen, or partial screen.

We're exploring different reasons this may be happening.

Status Page powered by Admin Labs