Turnio - Turn is currently experiencing a major outage – Incident details

All systems operational

Turn is currently experiencing a major outage

Resolved
Major outage
Started 8 months agoLasted 24 minutes
Updates
  • Resolved
    Resolved
    The fix for the major disruption impacting the platform has been deployed and this issue is now mitigated. Thank you for your patience.
  • Update
    Update
    Nature of the issue: We are currently experiencing a major disruption impacting our system. When it started: This issue began on October 18th, 2024, at 3:00 PM UTC. Our engineering teams are actively investigating the problem. When to expect the next update: We will provide another update as soon as more information becomes available.
  • Investigating
    Investigating