Started over 4 years agoMarch 11, 2022Lasted about 1 hourMarch 11, 202212:031:30 AMUTC
Updates
Resolved
UTC
Resolved
UTC
Further monitoring reveals no further delays in message receipt and delivery. This issue has therefore been resolved.
Monitoring
UTC
Monitoring
UTC
The cause of the delay has been identified and rectified. All numbers should be operational again. Turn engineers are continuing to monitor the situation.
Update
UTC
Update
UTC
A delay in message receipt and delivery has been observed on certain numbers. Turn engineers are investigating.