Turnio - Turn/Collection/Automation not loading – Incident details

UI & Helpdesk experiencing degraded performance

Turn/Collection/Automation not loading

Resolved
Major outage
Started over 4 years agoLasted 42 minutes
Updates
  • Resolved
    Resolved
    The issue pertaining to loading of conversations is now resolved. All features are working as expected.
  • Update
    Update
    We have encountered an error at our end due to which either turn is not loading or the collections/automations are not available. This is impacting all clients on app.turn.io. It is not impacting private clouds. Our engineers are working to get it resolved as soon as possible.
  • Investigating
    Investigating