Turnio - Application loading issues due to outages in content distribution network – Incident details

UI & Helpdesk experiencing degraded performance

Application loading issues due to outages in content distribution network

Resolved
Major outage
Started over 4 years agoLasted 3 days
Updates
  • Resolved
    Resolved
    Content distribution network outage ended. All systems are working as expected.
  • Update
    Update
    The content distribution network that is used to serve the Turn frontend application is currently experiencing a major outage. This outage might impact some of our clients. Some of our clients might not be able to load the turn application. We are monitoring the situation.
  • Investigating
    Investigating