Turnio - Turn is Currently Experiencing partial login issues related to Google Cloud Platform outage – Incident details
All systems operational
Turn is Currently Experiencing partial login issues related to Google Cloud Platform outage
Resolved
Major outage
Started 7 months agoLasted about 3 hours
Updates
Resolved
Resolved
The login issues caused by the Google Cloud Platform outage are no longer affecting access to Turn.io. Users should now be able to log in without any problems.
We’ll continue monitoring the situation closely. If you’re still experiencing issues or need any assistance, please don’t hesitate to reach out to our support team.
Monitoring
Monitoring
We are currently experiencing partial login issues on Turn.io due to an ongoing incident affecting several Google Cloud Platform services, including:
- Google Cloud Dataproc
- Google Cloud Storage
- Identity and Access Management (IAM)
As a result, some users may encounter difficulties logging into the platform. This issue is not affecting all users.
We are closely monitoring the situation and will provide updates as soon as more information becomes available. You can also follow Google’s status updates here: https://status.cloud.google.com/regional/europe
Thank you for your patience.