Turnio - Turn is Currently Experiencing Email Reminder Failures – Incident details

All systems operational

Turn is Currently Experiencing Email Reminder Failures

Resolved
Major outage
Started 29 days agoLasted about 2 hours
Updates
  • Resolved
    Resolved
    All email reminders, webhook alerts, and export insights are working again on all environment.
  • Identified
    Identified
    All email reminders, webhook alerts, and export insights are working again on the shared environment. Updates to private clouds currently being rolled out.
  • Investigating
    Investigating