Turnio - Turn is Currently Experiencing a major outage – Incident details

All systems operational

Turn is Currently Experiencing a major outage

Resolved
Major outage
Started about 1 month agoLasted 13 minutes
Updates
  • Resolved
    Resolved
    The issue has been resolved, the application is stable again. The instability was caused by an unexpected infrastructure load, which has been identified and addressed.
  • Update
    Update
    When can we expect next update: We will provide another update when additional information is available.
  • Investigating
    Investigating