Turnio - Turn is Currently Experiencing issues related to journey processing – Incident details
All systems operational
Turn is Currently Experiencing issues related to journey processing
Resolved
Major outage
Started over 1 year agoFebruary 20, 2025Lasted about 1 hourFebruary 20, 20254:155:11 PMUTC
Updates
Resolved
UTC
Resolved
UTC
We have identified a misbehaving customer journey that was stuck in a loop.
The issue has been found and addressed.
We are continuing to monitor the situation and working on improvements to prevent this from happening again.
Identified
UTC
Identified
UTC
Nature of the Issue:
We are currently experiencing a system overload that is impacting the delivery of journey messages.
When It Started:
This issue began on February 20, 2025, at 4 PM UTC. Our engineering teams are working to add more capacity to remediate the issue.
When can we expect next update:
We will provide another update when additional information is available.