Turnio - Turn.io is currently experiencing issues related to platform stability – Incident details

All systems operational

Turn.io is currently experiencing issues related to platform stability

Resolved
Major outage
Started 6 months agoLasted 27 minutes
Updates
  • Resolved
    Resolved
    The issue has been resolved, and the application is stable again. The instability was caused by an unexpected infrastructure load, which has been identified and addressed. We deeply regret any inconvenience this has caused. Should you continue to experience any problems, please don't hesitate to contact Turn support for assistance.
  • Update
    Update
    Nature of issue: We are currently experiencing disruptions affecting the platform's stability. You might be logged out repeatedly. Our team is working on the issue, and we hope to resolve it soon. When it started: This issue started on Jan 22nd 2025 at 18pm UTC. Our engineering teams are investigating the issue. When can we expect next update: We will provide another update when additional information is available.
  • Investigating
    Investigating