Turnio - Application loading issues – Incident details
Get updates
Email
API
Get updates
All systems operational
Application loading issues
Resolved
Major outage
Started over 3 years ago
Lasted about 1 hour
Updates
Resolved
October 21, 2021 at 7:59 AM
Resolved
October 21, 2021 at 7:59 AM
The issue has been resolved.
Update
October 21, 2021 at 7:15 AM
Update
October 21, 2021 at 7:15 AM
We have observed an issue with the Turn user interface not loading correctly or loading slowly. This is impacting some of our clients. Our team is working on the issue. We hope to resolve it soon.
Investigating
October 21, 2021 at 7:14 AM
Investigating
October 21, 2021 at 7:14 AM