Turnio - Google login issues – Incident details

All systems operational

Google login issues

Resolved
Major outage
Started about 5 years agoLasted about 2 hours
Updates
  • Resolved
    Resolved
    Google seems to have resolved most of their issues.
  • Update
    Update
    Google is having a global outage and Turn relies on Google for login and account management. While Google is having these problems, you may face issues while logging into any Turn instance.
  • Investigating
    Investigating