Started over 5 years agoNovember 27, 2020Lasted about 4 hoursNovember 27, 202010:41 AM2:23 PMUTC
Updates
Resolved
UTC
Resolved
UTC
The issue has been resolved.
Update
UTC
Update
UTC
We've found an issue with automations that is impacting numbers who have more than 50 pieces of content loaded in Turn. We're busy addressing this issue.