Turnio - Turn.io is Experiencing an Outage – Incident details

All systems operational

Turn.io is Experiencing an Outage

Resolved
Major outage
Started 19 days agoLasted about 5 hours

Affected

Messaging & API

Operational from 11:23 AM to 11:30 AM, Degraded performance from 11:30 AM to 11:55 AM, Operational from 11:55 AM to 4:14 PM

UI & Helpdesk

Major outage from 11:23 AM to 11:55 AM, Operational from 11:55 AM to 4:14 PM

Updates
  • Resolved
    Resolved

    Our systems experienced a period of degraded performance. This began with an unexpected surge in background processing, which put unusual pressure on our database. At the same time, a suspected issue with Cloudflare contributed to delays in some of our internal processes. Together, these factors created a rare chain reaction that temporarily slowed down parts of our platform.
    Although Cloudflare’s wider incident is still ongoing, our services have now returned to normal and remain stable.

    We’re applying additional safeguards to ensure this can’t happen again.

    Thank you for your patience while we resolved this.

  • Monitoring
    Monitoring

    This incident has been resolved. We are observing to ensure that nothing goes wrong again.

  • Identified
    Identified

    We are continuing to work on a fix for this incident. Responses on some WhatsApp lines are delayed.

  • Investigating
    Investigating

    We are aware that https://whatsapp.turn.io/app/ is not responding or loading. We are currently investigating this incident with the highest priority.