Turnio - Turn is currently experiencing delays on message processing – Incident details

All systems operational

Turn is currently experiencing delays on message processing

Resolved
Degraded performance
Started 3 days agoLasted about 8 hours

Affected

Messaging & API

Degraded performance from 11:57 AM to 7:58 PM

UI & Helpdesk

Degraded performance from 11:57 AM to 7:58 PM

WhatsApp Cloud API

Degraded performance from 11:57 AM to 7:58 PM

Updates
  • Resolved
    Resolved
    Our engineering team identified database performance degradation due to high data volume and suboptimal query patterns. Immediate mitigation steps have been taken. We will continue to monitor the system closely. Thank you for your patience.
  • Investigating
    Investigating
    We are currently investigating this incident.