Turn.io Status Page

Incident

Turn Web UI is not loading.

Resolved | Apr 08, 2024 | 18:55 GMT+02:00

All issues have been resolved and Turn is working as expected.

Investigating | Apr 08, 2024 | 18:50 GMT+02:00

We have identified an issue with the Turn WebApp UI. Turn's web page fails to load or update in the browser.

The above issue is impacting all customers on our shared cluster at https://whatsapp.turn.io. Private cloud customers are also affected.

Please note that the messaging service is not affected.

We are working to resolve the issue as quickly as possible.

Status Page powered by Admin Labs