Turn.io Status Page

Incident

Issue with Collections on Turn Helpdesk

Resolved | Apr 30, 2024 | 15:34 GMT+02:00

The issue with collections has been resolved and organizations should be able to view their collections again.

Resolution in progress | Apr 30, 2024 | 13:45 GMT+02:00

There is currently an ongoing issue with the Collections on helpdesk and some Turn SaaS accounts are unable to see their collections.

We have identified the issue and are looking to release a fix shortly.

Status Page powered by Admin Labs