Turn.io Status Page

Incident

Outages of Meta Cloud API reported on their Status Page

Resolved | Apr 11, 2024 | 15:19 GMT+02:00

The fix for the major disruption impacting message delivery on Meta Cloud API has been deployed and this issue is now mitigated as of April 11th 4:30AM GMT.

Thank you for your patience.

Reference: https://metastatus.com/whatsapp-business-api

Identified | Apr 11, 2024 | 13:11 GMT+02:00

We had identified an issue with Meta business products experiencing an outage.

Reference: https://metastatus.com/

Status Page powered by Admin Labs