Turn.io Status Page

Incident

Delayed messaging delivery

Resolved | Mar 11, 2022 | 02:30 GMT+01:00

Further monitoring reveals no further delays in message receipt and delivery. This issue has therefore been resolved.

Monitoring | Mar 11, 2022 | 01:39 GMT+01:00

The cause of the delay has been identified and rectified. All numbers should be operational again. Turn engineers are continuing to monitor the situation.

Open | Mar 11, 2022 | 01:04 GMT+01:00

A delay in message receipt and delivery has been observed on certain numbers. Turn engineers are investigating.

Status Page powered by Admin Labs