Turn.io Status Page

Incident

Node pool repairs

Resolved | Nov 21, 2023 | 20:45 GMT+01:00

All issues have been resolved and Turn is working as expected.

Identified | Nov 21, 2023 | 20:07 GMT+01:00

The repairs are taking longer than anticipated, we're creating extra capacity to give the platform redundant capacity while repairs are taking place.

Open | Nov 21, 2023 | 19:54 GMT+01:00

Our underlying managed infrastructure is undergoing automated repairs by Google Cloud on the Turn SaaS platform. This is causing disruption across multiple numbers as services are being migrated from poorly performing server nodes to newly provisioned server nodes.

Status Page powered by Admin Labs