Turn.io Status Page

Incident

New major outage at Meta that impacts message delivery

Resolved | Apr 03, 2024 | 23:30 GMT+02:00

The issue is resolved by Meta engineering team.

We deeply regret any inconvenience this has caused. Should you continue to experience any problems, please don't hesitate to contact Turn support for assistance.

Identified | Apr 03, 2024 | 20:54 GMT+02:00

Meta is experiencing a significant disruption that affects the delivery of messages for all numbers via the Cloud API and On-Premise API. This issue started on 04-03-2024 at 11:18 AM PST.

We are monitoring the situation and update you as soon as the Meta team has resolved the issue.

Reference: https://metastatus.com/

Status Page powered by Admin Labs