Turn.io Status Page

Incident

Delay in message processing

Resolved | Jun 04, 2022 | 09:27 GMT+02:00

The cause for message processing delay has been identified and rectified. This incident did not affect all numbers, however those numbers affected would have seen intermittent delays in message processing. Normal operation has been restored.

Investigating | Jun 04, 2022 | 06:36 GMT+02:00

We have identified further delays in message processing, Turn engineers are investigating.

Resolved | Jun 04, 2022 | 05:08 GMT+02:00

Whilst some additional message processing delay was observed whilst monitoring, no delays are currently being observed.

Monitoring | Jun 04, 2022 | 03:01 GMT+02:00

The cause for message processing delay has been identified and rectified. We are continuing to monitor the situation.

Open | Jun 04, 2022 | 02:15 GMT+02:00

There's currently a delay in messages being processed, Turn engineers are investigating.

Status Page powered by Admin Labs