Turn.io Status Page

Incident

Turn interface is not loading

Resolved | Apr 25, 2023 | 11:46 GMT+02:00

Turn interface is now loading for all clients. The underlying issue is resolved.

Investigating | Apr 25, 2023 | 09:37 GMT+02:00

The turn interface is loading for most of the clients. However, we still some disruptions. We are working to get it resolved as soon as possible.

Open | Apr 25, 2023 | 08:01 GMT+02:00

We have identified an issue due to which the Turn interface is not loading.

The above issue is impacting all customers on our shared cluster https://whatsapp.turn.io and private clusters.

We are working to resolve the issue as quickly as possible.

Status Page powered by Admin Labs