Turn.io Status Page

Incident

The People page is intermittently failing to load

Resolved | Jul 08, 2024 | 16:05 GMT+02:00

A fix has been deployed.
We are currently monitoring it.

Investigating | Jul 08, 2024 | 15:33 GMT+02:00

We have identified an issue with the People feature. The page fails to load.

The above issue is impacting some customers on our shared cluster at https://whatsapp.turn.io. It may cause slowness to the platform and affect all customers.

We are sorry for the inconvenience and are working to resolve the issue as quickly as possible.

Status Page powered by Admin Labs