Turn.io Status Page

Incident

Major outage at Meta that impacts message delivery.

Resolved | Mar 27, 2024 | 11:24 GMT+01:00

The issue is resolved.

Monitoring | Mar 27, 2024 | 05:24 GMT+01:00

The issue is resolved by Meta engineering team. We are monitoring our systems.

Open | Mar 27, 2024 | 04:46 GMT+01:00

Meta is experiencing a significant disruption that affects the delivery of messages for all numbers via the Cloud API. This issue started at March 26, 2024, 7:55:47 PM PDT.

We are monitoring the situation and update as soon as Meta team has resolved the issue.

Status Page powered by Admin Labs