Turn.io Status Page

Incident

Delay in message processing

Resolved | May 25, 2022 | 22:07 GMT+02:00

No further message processing delay has been observed, the issues has been resolved.

Monitoring | May 25, 2022 | 20:18 GMT+02:00

The cause for message processing delay has been identified and rectified. Only a select number of numbers were affected. We are continuing to monitor the situation.

Open | May 25, 2022 | 19:45 GMT+02:00

There's currently a delay in messages being processed, Turn engineers are investigating.

Status Page powered by Admin Labs