Turn.io Status Page

Incident

Outages of Meta business products reported on their Status Page

Resolved | Mar 06, 2024 | 06:41 GMT+01:00

We had identified an issue with Meta business products experiencing an outage. Reference: https://metastatus.com/

Meta has now resolved the issue.

Monitoring | Mar 05, 2024 | 19:54 GMT+01:00

https://metastatus.com/

We will keep you informed as soon as Meta establishes the status of their products.

Open | Mar 05, 2024 | 17:37 GMT+01:00

We have identified that Meta business products are experiencing an outage. Reference: https://metastatus.com/

The above issue is affecting campaigns, local storage, and signups.

Customers on our shared cluster at https://whatsapp.turn.io and Private Cloud customers are also experiencing disruptions.

We will keep you informed as soon as Meta establishes the status of their products.

Status Page powered by Admin Labs