Turn.io Status Page

Incident

Delays in automated reponses

Resolved | Jul 25, 2023 | 17:48 GMT+02:00

The issue related to delayed responses is resolved.

Investigating | Jul 25, 2023 | 13:31 GMT+02:00

We have identified an issue that is causing the delay in automated responses. This impacts all clients in Turn shared cluster.

We are investigating the issue.

Status Page powered by Admin Labs