Turn Status Page logo

Incident

Service disruption due to load balancer outage

Resolved | Nov 16, 2021 | 19:48 GMT+01:00

Turn application and messaging service operation has now been restored.

Monitoring | Nov 16, 2021 | 19:20 GMT+01:00

Turn application and messaging services are now accessible but might still have degraded performance.

We are continuing to monitor the situation as Google continues to address a Cloud Networking outage.

Open | Nov 16, 2021 | 19:05 GMT+01:00

The load balancing service used to serve the Turn application and messaging services is currently experiencing a major outage. As a result Turn is unable to process messages at this time.

We are continuing to monitor the situation.

Status Page powered by Admin Labs