Turn.io Status Page

Incident

Multiple messages delivered via Reminders

Resolved | Feb 22, 2023 | 15:06 GMT+01:00

Duplicate reminders issue has been resolved.

Monitoring | Feb 06, 2023 | 12:37 GMT+01:00

We have shipped a fix for the duplicate message delivery observed in Reminders, and will continue to monitor it closely. The feature can be used again as usual.

Open | Feb 03, 2023 | 08:02 GMT+01:00

We are experiencing issues with Reminders resulting in multiple messages being sent to contacts. This could impact quality ratings and we therefore recommend to not use Reminders until the issue is resolved.

The above issue is impacting all customers on our shared cluster at as well as private cloud customers.

We are actively working to resolve it.

Status Page powered by Admin Labs