Turn Status Page logo

Incident

Database changes interrupting message processing.

Resolved | Nov 10, 2020 | 16:42 GMT+01:00

The issue has been resolved for all Turn installations.

Monitoring | Nov 10, 2020 | 13:11 GMT+01:00

The issue is resolved on app.turn.io, we're monitoring the situation on the private cloud installations.

Status Page powered by Admin Labs