Turn.io Status Page

Incident

Conversations page not loading

Resolved | Jun 26, 2023 | 16:17 GMT+02:00

All issues have been resolved.

Resolution in progress | Jun 26, 2023 | 15:51 GMT+02:00

Conversations are loading. We are addressing an issue with automations not working.

Resolved | Jun 26, 2023 | 15:39 GMT+02:00

The conversation loading issue has been resolved.

Open | Jun 26, 2023 | 15:18 GMT+02:00

We have identified an issue on the shared Turn cluster resulting in the conversation page not loading. The issue is not impacting private cloud customers.

We are working to resolve the issue as quickly as possible.

Status Page powered by Admin Labs